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Installing the Android Development Environment

Installation of the recommended development environment (which uses Eclipse™ as an IDE) is simply a
matter of:

Verifying that your development computer meets the minimum requirements

Downloading and installing the Android™ SDK

Downloading and installing Eclipse (if you already have a suitable version of Eclipse [as noted in the
System Requirements] installed on your development computer, you can skip this step)

Using Eclipse’s Software Update mechanism to download and install the Android Development Tools

(ADT)

Once you have installed all of the necessary software, you can verify your installation by creating a quick
“Hello World"-style application and deploying it on an emulated Android handset.

Verify That you Meet the System Requirements

Before installing, you must verify that your development
computer meets the system requirements set out by

Google™.

1 Point your web browser to http://developer.android.com/.
Click the SDK tab at the top of the page.

2 On the left side of the page, under “Current SDK
Release”, click System Requirements.

3 Ensure that your machine is running one of the listed

operating systems, and that it has the proper JDK (Java
Development Kit) as listed under “Eclipse IDE”.

If you need the JDK (the JRE alone is not sufficient; you
need the full JDK), download the latest from http://
java.sun.com/javase/downloads/index.jsp and install it.
Download the 32-bit version even if you have a 64-bit
computer and operating system.
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Download and Install the Android SDK

Point your web browser to http://developer.android.com/. Click the SDK tab at the top of the page.
On the left side of the page, under “Current SDK Release”, click Download.

Click the appropriate link to download the SDK for your host platform. Note that you will need to agree
to the terms of the Android SDK License Agreement.

Unzip the downloaded file to a directory of your choosing on your development computer. Within the
chosen directory, the zip file unpacks as a directory named for the platform, release, and build (for
instance, android-sdk-mac_x86-1.5_r1).

So that you don't have to supply the full path to the Android tools directoryl when running tools from
the command line, add it to your path:

«  On Microsoft® Windows®, right-click My Computer and select Properties. Select the Advanced
tab and click Environment Variables. In the Environment Variables dialog, under System
Variables, select Path and click Edit. Append the full path to the tools directory, separating it from
the preceding path using a semicolon. Close all dialogs.

e On Linux®, edit your ~/ .bash_profile or ~/.bashrc file. If either sets the PATH environment
variable, edit it so that it includes the full path to the tools directory. If neither file sets PATH, add
the following line to either of the files:

export PATH=${PATH}:full_path_to_your_android_sdk_tools_dir

«  On Mac OS® X, look for a .bash_profile file in your home directory. If this file doesn't exist,
create it with a single entry:
export PATH=${PATH}:full_path_to_your_android_sdk_tools_dir

If you already have a .bash_profile file, check to see if it sets the PATH environment variable. If
so, edit it so that it includes the full path to the tools directory. Otherwise, add the above line to it.

Download and Install Eclipse

1

Go to http://www.eclipse.org/downloads/. Find the entry labeled “Eclipse Classic” (as of this writing,
version 3.4.2) and click the link on the right side appropriate for your platform.

From the page that appears, download the archive (.zip or .targ.gz depending upon your platform).

Extract the downloaded file to an appropriate location, such as C:\Program Files\ or
/Applications/. Extraction creates a directory named ecl ipse within the chosen location.

If desired, create a shortcut that will simplify the launching of Eclipse:

* On Windows, open the eclipse folder, right click eclipse.exe, select Send To, and then select
Desktop (create shortcut).

* On Mac OS X, open the eclipse folder and drag Eclipse.app to the Dock.

1. This is the directory named tools within the unpacked Android SDK directory. For instance, C:\android-sdk-
windows-1.5_ril\tools.
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5 Launch Eclipse. You will be asked to select a workspace:

& Workspace Launcher

X

Select a workspace

Eclipse SDE stores your projects in a folder called a workspace,
Choose a workspace folder o use For this session,

‘Workspace: w | [ Browse, ..

[Juse this as the default and do not ask again

[ Ok H Cancel ]

6 Specify a directory into which all of your Android projects should be stored. Note that you will probably
want to create a new directory just for this purpose. If you do not want to be prompted for a workspace

directory each time you launch Eclipse, select Use this as the default and do not ask again. Finally,
click OK.

Eclipse launches, and the Welcome view appears.

7 On the right side of the Welcome view, click the “Go to the Workbench” icon: n
You should now see the Eclipse workbench:

9 Java - Eclipse SDK - /Users/gregw/Documents /workspace5
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Install the Android Development Tools (ADT)

NOTE: Eclipse uses its own proxy settings (and not those of your host computer) when accessing the
Internet. If you access the Internet through a proxy server, you must configure Eclipse
accordingly. Select Preferences from the Window menu (on Mac OS X, Preferences are
located in the Eclipse menu). On the left side of the Preferences dialog, expand General and
select Network Connections. Select Manual proxy configuration and fill in the fields as
appropriate for your network setup. (Note that the Android Development Tools are installed
using https; thus, you need to configure the SSL proxy.) Click OK when done.

1 From within Eclipse, select Software Updates from the Help menu. The Software Updates and Add-
ons dialog appears.

2 Atthe top of the dialog, click Available Software.

3 On the right side of the dialog, click Add Site. The Add Site dialog appears.

4 Enter the following URL into the Location field and click OK:
https://dl-ssl_google.com/android/eclipse/

5 The URL you just added should now appear in the Available Software list. Click the checkbox to the
left of it, and then click Install.

& Software Updates and Add-ons |:|@@

Installed Software | Awailable Software

bype filker bext -

Mame Wersion Install...

] %| Ganymede Update Site

= # https://dl-ssl.google. com{android/eclipse

= [#] 000 Developer Tacls

=# Android DDMS 0.9.0,w200904221245-147402
= Android Development Tools 0,9.0,v200904221248-147402

O | The Eclipse Project Updates Add Site...

Manage Sites. ..

Show only the latest versions of available software

[Jinclude items that have already been installed

Open the ‘Automatic Updates' preference page to set up an automatic update schedule,

~J,

Close

6 When the Install dialog appears, asking you to review and confirm the software being installed, click
Next.

7 You are now asked to review and accept the licenses for the software being installed. If you accept
them, select | accept the terms of the license agreements and then click Finish.

The Android Development Tools are downloaded and installed.
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8 When installation is complete, you will be asked if you want to restart Eclipse. Click Yes and let it restart.

Once Eclipse has restarted, you have one last task to perform: you need to tell Eclipse where the Android
SDK resides.

9 Open the Preferences dialog (on Windows or Linux, Window > Preferences; on Mac OS X, Eclipse >
Preferences).

10 On the left side of the Preferences dialog, click Android. A warning dialog appears, indicating that the
location of the Android SDK has not been set up. Click OK to dismiss the warning.

11 In the SDK Location field, specify the directory that contains the Android SDK.

12 Click OK to register the SDK with Eclipse and close the Preferences dialog.

& Preferences |:|@@

type Filker text Android

General Android Preferences
Android

Ant SDK Location: | C:handroid-sdk-windows-1,5_r1

Help Mote: The list of SDK Targets below is only reloaded once you hit ‘apply' or 'Ok,

InstallfUpdate

Java Target Mame Wendor Platform  AP...
Plug-in Development Android 1.1 Android Open Source Project 1.1 2
Run/Debug Android 1.5 Android Open Source Project 1.5 3
Team Google APIs Google Inc, 1.5 3

e

ML

Test Your Installation

First, you must create at least one Android Virtual Device (AVD)* to which you can deploy applications.
Note that AVDs can be re-used; you need not create a new one each time you want to run an application.

1 Open a Command Prompt (a Terminal window).

2 Change to the Android SDK Tools directory. For instance:
cd \android-sdk-windows-1.5_ri1\tools

3 Enter the following command to create an AVD named “androidl 5"
android create avd -n androidl 5 -t 3

The “-t 3” specifies that the target device runs Android 1.5 (API level 3) and supports the Google APIs;
to create a target running Android 1.1, you would use “-t 1” instead.

Now, from within Eclipse, you can create and run an application:
1 Click File > New > Other. From the list of wizards, select Android > Android Project and click Next.

The New Android Project dialog appears.

1. Each AVD is a particular configuration of hardware options, system image, data storage, and an emulator “skin,” all of
which emulates an actual device. You can create multiple AVDs to enable testing on different emulated device types.
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2 Fill out the dialog as shown below (making sure to select Android 1.5 as the Build Target), and click
Finish.

& New Android Project

New Android Project
Creates a new Android Project resource, q

Project name: | HelloAndroid

Contents

@ Create new project in workspace
O Create project from existing source
Use default location

Build Target
Target Mame Wendor Flatform APL..

[ android 1.1 Android Open Source Project 1.1 2

Android 1.5 Android Open Source Project 1.5 3

[] Google &PIs Google Inc, 1.5 3

Standard Android platform 1.5
Properties
Application name: | Hello, Android |
Package name: | com.example. helloandroid |
Create Activity: | helloandroid| |
Min SDK Version: | 3 |
':':’:' [ Finish ] [ Cancel ]

The project is created and added to the Package Explorer.

NOTE: If you see errors in the Console view (“no classfiles specified”) and the project name in the
Package Explorer has a small red “X" icon attached to it, right-click the project name in the
Package Explorer and select Refresh.

3 Right-click HelloAndroid in the Package
Explorer, and select Run As > Android
Application.

M Android Emulator {android1_5:5554)

The emulator launches in a separate
window. Note that the emulator takes a few
minutes to fully launch.

11:22 PM

ld, helloAndroid!

Watch Eclipse’s Console view for an
indication of how the launch is proceeding. In particular, when the “Uploading...” and “Installing...”
messages appear, your application is being transferred to the emulated device. Then, the “Starting
activity...” message indicates that your application is being launched.
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Android

[2009-04-29 16:19:03 Hellobindroid]

[2009-04-29 16:19:03 Hellodndroid] Android Launch!

[2009-04-29 16:19:03 Hellodndroid] adb is running normally.

[2009-04-29 16:19:03 Hellodndroid] Performing com.examwple.hellodndroid.hellodndroid activ
[2009-04-29 16:19:03 Hellodndroid] Automatic Target Mode: launching new emulator with com
[2009-04-29 16:19:03 Helloindroid] Launching a new emulator with Virtual Device 'androidl
[2009-04-29 16:19:13 Hellodndroid] New emulator found: emulator-5554

[2009-04-29 16:19:13 Hellodndroid] Waiting for HOME ('android.process.acore')] to bhe launc!
[2009-04-29 16:21:54 Hellodndroid] HOME is up on device 'emulator-5554°

[2009-04-29 16:21:54 Hellodndroid] Uploading Hellokndroid.apk onto device 'emulator-5554°
[2009-04-29 16:21:54 Hellodndroid] Installing Hellobkndroid.apk...

[2009-04-29 16:22:32 Hellodndroid] Success!

[2009-04-29 16:22:32 Hellodndroid] Starting activity com.example.hellodndroid.hellodndroi
[2009-04-29 16:22:42 Hellodndroid] ActivityManager: 3tarting: Intent { comp={com.exsmple.!
£ >
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ECCN 5E991.NR: In accordance with United States Export Administration Regulations (EAR), and specifically the Commerce Control
List (CCL), this item has been classified 5E991.NR. Export or re-export of this commodity and compliance with the U.S. Export
Administration Regulations is ultimately the responsibility of the exporter. For more detailed information related to export or re-export
of this item, please consult the EAR at http://www.access.gpo.gov/bis/ear/ear_data.html.

Copyright © 2009, Motorola, Inc. All rights reserved.

This documentation may be printed and copied solely for use in developing products for Motorola products. In addition, two (2) copies
of this documentation may be made for archival and backup purposes. Except for the foregoing, no part of this documentation may be
reproduced or transmitted in any form or by any means or used to make any derivative work (such as translation, transformation, or
adaptation) without express written consent from Motorola, Inc.

Motorola reserves the right to make changes without notice to any products or services described herein. "Typical" parameters, which
may be provided in Motorola Data sheets and/or specifications, can and do vary in different applications and actual performance may
vary. Customer's technical experts will validate all "Typicals" for each customer application.

Motorola makes no warranty in regard to the products or services contained herein. Implied warranties, including without limitation,
the implied warranties of merchantability and fitness for a particular purpose, are given only if specifically required by applicable law.
Otherwise, they are specifically excluded.

No warranty is made as to coverage, availability, or grade of service provided by the products or services, whether through a service
provider or otherwise. No warranty is made that the software will meet your requirements or will work in combination with any
hardware or application software products provided by third parties, that the operation of the software products will be uninterrupted
or error free, or that all defects in the software products will be corrected.

In no event shall Motorola be liable, whether in contract or tort (including negligence), for any damages resulting from use of a product
or service described herein, or for any indirect, incidental, special or consequential damages of any kind, or loss of revenue or profits,
loss of business, loss of information or data, or other financial loss arising out of or in connection with the ability or inability to use the
Products, to the full extent these damages may be disclaimed by law.

Some states and other jurisdictions do not allow the exclusion or limitation of incidental or consequential damages, or limitation on the
length of an implied warranty, therefore the above limitations or exclusions may not apply to you.

This warranty gives you specific legal rights, and you may also have other rights, which vary from jurisdiction to jurisdiction.

Motorola products or services are not designed, intended, or authorized for use as components in systems intended for surgical
implant into the body, or other applications intended to support or sustain life, or for any other application in which the failure of the
Motorola product or service could create a situation where personal injury or death may occur.

Should the buyer purchase or use Motorola products or services for any such unintended or unauthorized application, the buyer shall
release, indemnify and hold Motorola and its officers, employees, subsidiaries, affiliates, and distributors harmless against all claims,
costs, damages, and expenses, and reasonable attorney fees arising out of, directly or indirectly, any claim of personal injury or death
associated with such unintended or unauthorized use, even if such claim alleges that Motorola was negligent regarding the designing
or manufacturing of the product or service.

Motorola recommends that if you are not the author or creator of the graphics, video, or sound, you obtain sufficient license rights,
including the rights under all patents, trademarks, trade names, copyrights, and other third party proprietary rights.

If this documentation is provided on compact disc, the other software and documentation on the compact disc are subject to the
license agreement accompanying the compact disc.

MOTOROLA and the Stylized M Logo are registered in the US Patent & Trademark Office. Java and all other Java-based marks are
trademarks or registered trademarks of Sun Microsystems, Inc. in the US and other countries. Eclipse is a trademark of Eclipse
Foundation, Inc. Google and Android are trademarks of Google Inc. Microsoft, Windows and Windows Me are registered trademarks
of Microsoft Corporation; and Windows XP and Windows Vista are trademarks of Microsoft Corporation. Linux is the registered
trademark of Linus Torvalds in the U.S. and other countries. Mac and Mac OS are trademarks of Apple Inc., registered in the U.S.
and other countries. All other product and service names are the property of their respective owners.
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